Unable to upgrade/install Plesk on Ubuntu/Debian: the following packages have unmet dependencies

Install Plesk on Ubuntu. Running the plesk installer results in failure.

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming.
The following packages have unmet dependencies:
apache2 : Depends: apache2.2-common (= 2.2.22-13+deb7u3) but it is not going to be installed
apache2-mpm-prefork : Depends: apache2.2-common (= 2.2.22-13+deb7u3) but it is not going to be installed
Depends: apache2.2-bin (= 2.2.22-13+deb7u3) but it is not going to be installed
mysql-server : Depends: mysql-server-5.5 but it is not going to be installed
plesk-base : Depends: sw-engine (>= 2.13.8) but it is not going to be installed
plesk-core : Depends: libcurl3 (>= 7.16.2) but it is not going to be installed
awstats : Depends: perl:any
libapache2-mod-bw : Depends: apache2-api-20120211
libapache2-mod-perl2 : Depends: apache2-api-20120211
Depends: libxslt1.1 (>= 1.1.25) but it is not installable
Depends: libmyodbc but it is not installable
Depends: xsltproc but it is not installable
Depends: libtimedate-perl but it is not installable

or

The apg-get failed with the following message: Reading package lists... Building dependency tree... Reading state information... You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: apache2 :
Depends: apache2-bin (= 2.4.18-2ubuntu3.9) but 2.4.18-2ubuntu3.8 is to be installed
Depends: apache2-data (= 2.4.18-2ubuntu3.9) but 2.4.18-2ubuntu3.8 is to be installed linux-image-virtual:
Depends: linux-image-4.4.0-128-generic but it is not going to be installed plesk-service-node-utilities:
Depends: libidn2-0 (>= 0.6) but it is not going to be installed

Cause
Non-standard repositories enabled in /etc/apt/sources.list file that Plesk is not compatible with, so a system cannot resolve all the dependencies properly.

Resolution
Connect to the server via SSH.

Replace all contents of the file /etc/apt/sources.list with the default content, like below:

Default sources.list for:
Ubuntu 18.04 LTS:

deb http://archive.ubuntu.com/ubuntu bionic main restricted universe
deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted universe
deb http://security.ubuntu.com/ubuntu bionic-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu bionic partner

Ubuntu 16.04 LTS:

deb http://archive.ubuntu.com/ubuntu xenial main restricted universe
deb http://archive.ubuntu.com/ubuntu xenial-updates main restricted universe
deb http://security.ubuntu.com/ubuntu xenial-security main restricted universe multiverse
deb http://archive.canonical.com/ubuntu xenial partner

Update package lists and install missing dependencies:

apt-get update
# apt-get -f install

Run Plesk installation / update / upgrade.

Source: https://support.plesk.com/hc/en-us/articles/213367169-Unable-to-upgrade-install-Plesk-on-Ubuntu-Debian-the-following-packages-have-unmet-dependencies